SAP Knowledge Base Article - Public

2437449 - 'Search Results' breadcrumb link disappears in LMS

Symptom

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

  • Within LMS, after modifying a field in the 'User Summary Record', the 'Search Results' link disappears.
  • Unable to return to search results after editing 'User Summary Record' in LMS.
  • Search results link disappears in LMS.

Image 1 with link.png

Image 2 no link.png

Environment

SAP SuccessFactors Learning Management System (LMS)

Reproducing the Issue

  1. Log into LMS as Admin and go to 'Users' tab.
  2. Search for a User and click their name from the list.
  3. In the 'User Summary Record' find 'Primary Supervisor' and edit field.
  4. Click Save.
  5. Observe 'Search Results' link disappears on 'User Summary Record'.

Cause

The 'Search Results' link is removed when modifying certain fields because the frame is reloaded, causing the previous search query to become invalid.

Resolution

This behavior is expected when editing certain fields in 'User Summary Record'.

Keywords

breadcrumb, bread crumb, Search results, link, snapshot, reload, user, user record, summary, modify, edit, change, Invalidated , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , Problem

Product

SAP SuccessFactors Learning all versions