Symptom
Click "Browse All Courses" from the "Find Learning" tile in the Learning user side, results in No Data.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Login as a Learning user >
- Navigate to the Learning home page >
- Click "Browse All Courses" in the Find Learning tile >
- "No Data" is displayed.
Cause
There are two possible causes of the "No Data" in the "Browse All Courses" search:
- There is an incorrect system configuration of the library related settings.
- Items are not marked as "Featured", "New" or "Revised" in the library for which the users have access to.
Resolution
To show all items in the library:
- Learning admin side > System Administration > Configuration > System Configuration >
- Edit the "LIBRARY" entry >
- Search for "catalogBrowseEnabled" and set it to false (catalogBrowseEnabled=false) >
- Apply Changes.
Or to enable the flag items feature:
- Learning admin side > Learning Activities > Libraries >
- Search for the affected/desired library ID >
- Go to the "Items" tab >
- Click the pencil (edit) icon >
- Update the column value of "Highlight As" for every item in the library >
- Select from "Revised", "New" or "Featured" >
- Save.
Keywords
No Data, library, Find Learning, tile, Browse All Courses, catalogBrowseEnabled, Highlight As, Featured, New, Revised, , KBA , LOD-SF-LMS-CAT , Catalog , LOD-SF-LMS , Learning Management System , Problem