SAP Knowledge Base Article - Public

2438008 - No Access to Oauth Token Server in System Configuration

Symptom

When navigationg to System Admin > Configuration, users are not able to see 'Oauth Token Server' and hence not able to genarate new client sectret key for webservices

Environment

SuccessFactors Learning Management System (LMS) - All Supported Versions

Reproducing the Issue

1. Navigate to System Admin > Configuration and you will not see Oauth Token Server listed there

Cause

Missing workflow 'Edit OAuth Token Server Settings' in admin role

Resolution

When an admin is not able to see the OAuth Token Server, it means that he/she is not having the workflow for the same.

Please add the workflow 'Edit OAuth Token Server Settings' to the admin's role.

Please follow the below steps:

  1. Navigate to System Admin > Security > Role Management
  2. Search for the respoective admin role in which the workflow needs to be added.
  3. Click on the edit icon and click on 'Workflows' tab
  4. Click on link 'add one or more from list' and then click on 'Expand All' link and search for workflow 'Edit OAuth Token Server Settings'
  5. Add the workflow to the role and click on 'Apply Changes'

The above steps will let the admin see the OAuth Token Server setting.

Keywords

OAuth token server, access, not able to generate client secret key, secret key, Edit OAuth Token Server Settings , KBA , LOD-SF-LMS-ODA , Web Services OData , Problem

Product

SAP SuccessFactors Learning all versions