SAP Knowledge Base Article - Public

2438063 - Fields Phone and Mobile Can Be Saved Without Data When Entering '.' If Set As Mandatory

Symptom

When the fields Phone and Mobile are set as Mandatory it is possible to perform a Save without the actual phone number being maintained if a '.' (full stop) is entered instead.

Reproducing the Issue

Prerequisite: Phone and Mobile fields are set to Mandatory on the Contact.

  1. Go to the Customers work centre.
  2. Go to the Contacts view.
  3. Create a new Contact.
  4. For the fields Phone and / or Mobile, enter a full stop '.'.
  5. Click Save.

RESULT: the full stop vanishes, however, the save is executed. Both fields now appear without value.

Cause

In the system in the Contact quick create view, the fields Phone and Mobile have been marked as Mandatory using the KUT (key user tools).

In such a case the mandatory check (if a field is empty or not) is performed at client level.
If '.' is entered, the client mandatory check goes through, but in the backend (BO) we have a parser for phone/mobile/fax which removes unnecessary characters (in this case '.') automatically and therefore it's possible to perform the save even if phone/mobile is empty.

This is expected system behaviour.

Resolution

If a "real" mandatory check is required and you want to guarantee that for every newly created contact in the system phone/mobile is filled we recommend to implement such a check via PDI.

Keywords

KBA , SRD-FIN-GL , General Ledger , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions