SAP Knowledge Base Article - Public

2438228 - Workflow Rule Notification Does Not Work For Changed Business Object

Symptom

You created a Workflow Rule for triggering notifications on objects change that does not work as expected.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Create a Workflow Rule for sending a notification for a user when a business object is changed.
  2. Change the related business object.
  3. Notice that a notification was not generated for the user

Cause

  • Whenever conditions in the Workflow Rule are satisfied, Tasks are created and the responsible is notified about it;
    • If the business object instance is modified then the existing Task is only updated but not created again and hence the user is not notified;
  • Also for each Task there is a deadline associated. Until the deadline is reached all tasks will only be updated;
    • If the deadline has crossed then a new Task will be created.

This design was made to prevent the huge number of notifications from flooding the system whenever a business object instance is only modified.

Resolution

This is the current system design. One way to workaround it is to get notified by e-mail whenever a change is made, using other rule type (e-mail) instead of notification.

Keywords

workflow rule, on every save, no new , KBA , LOD-CRM , Cloud for Customer , How To

Product

SAP Cloud for Customer add-ins all versions