SAP Knowledge Base Article - Public

2438850 - OBT Synchronization Shows Postponed Itineraries

Symptom

When an OBT Synchronization run is executed, you notice that the run logs have a big number of postponed itineraries.

Reproducing the Issue

  1. Go to the Application and User Management Workcenter.
  2. Go to the Background jobs View.
  3. Click on Show and select All Jobs run in last Week.
  4. Select a job with Run Type as OBT Synchronization Run.
  5. Click on View Application Log.

You see messages like Itineraries: XX replicated, XX processed, XXX postponed, XX cleaned up.

You see a bigger number of postponed Itineraries.

Cause

With each replication process only one itinerary per user gets processed (but all itineraries for all users that are in the queue are replicated). Usually only the first one gets processed. However, if that is in status pending approval that would block all following itineraries for that user until it is approved or declined (because only then it is deleted from the queue). This is usually not a problem for real life data, but since you use one test user it shows up as an issue.

Resolution

If you are testing approval workflow for itineraries, try to process the approval as fast as possible. Also you can book itineraries for different users.

Keywords

KBA , LOD-TEM-TP , Travel Plan / Itinerary , How To

Product

SAP Cloud for Travel and Expense all versions