SAP Knowledge Base Article - Public

2438919 - People Profile - Employee Central Mobile unable to use ESS (Employee Self Service) Function

Symptom

ESS function is not working on Mobile with People Profile:

ESS Mobile Cargill.PNG

Environment

Employee Central Mobile, People Profile - PP3

Reproducing the Issue

1. Login to SuccessFactors Mobile

2. Access Profile and try to use Employee Self Service Function

3. ESS tile would fail to load and you would only see a "PP3 Tile" with a refresh button beneath it

Cause

This issue is currently being investigated by SuccessFactors mobile development team.

Resolution

This is a known issue pending for the Mobile Development team to fix. As a workaround please do the following steps:

1. Login user account in Web browser.

2. Go to Admin Center > Employee Files > Configure People Profile

3. Check description text of every block or section and remove any and all double quotes. Once you have corrected all block description text that contained the special character, please try to reproduce in the Mobile app again. Please note that block description is only available for EP Background Info blocks: see attached screenshot below for an example.

PP3_ESS_Mobile_BlockDesc.jpg

Please let us know if you encounter further issues after applying the workaround recommended above by raising a support case.

Keywords

EC Mobile People profile ESS Not working, Employee Central Mobile ESS not working on People profile, ECT-68642, Mobile issue with ESS function , KBA , LOD-SF-EC-MOB , Employee Central Mobile , LOD-SF-EP , People Profile (Employee Profile / PP3) , Problem

Product

SAP SuccessFactors HCM Core 1611