Symptom
You have created an extension field in Employee screen in order to use this custom field in Employee Replication. However, the field is not available in WSDL file of Communication Arrangement Employee Replication from SAP Business Suite.
Reproducing the Issue
- Go to Application and User Management and select Communication Arrangements
- Open the Communication Arrangement Employee Replication from SAP Business Suite
- In Inbound Communication Services select the option Download WSDL
- Open the WSDL file
- The extension field you have created is not available
Cause
The field was not extended properly because it was not added to the right section of employee master data.
Please refer to text below extracted from documentation of Service Interface Replicate Employee from SAP Business Suite.
"This the service can be extended at the Personal Details information level, the WSDL will be extended automatically.The data given in the extension field(s) is being stored at the Employee Common node.
Interfaces used for IDOC integration will not be extended automatically.".
Resolution
You must create the extension field in Personal Data section of Employee Replication Request.
The steps described below explain how to create the same
- Launch your system in Silverlight client
- Go to Data Integration-> Complete Employee Data Replication
- Open any employee record
- Go to Adaptaion Mode, create an extension field under any Personal Data facet
- Once you create the field, you can use further usage and extend this field to service interface HumanCapitalManagementMasterDataReplicationEmployeeMasterDataReplicationIn
- Then the WSDL you download from Communication Arrangement will contain this extension field.
Keywords
KBA , LOD-CRM-EMP , Employee , How To