Symptom
When adding an Involved Party to an Appointment, the search query Related to Account is not visible in the UI.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Activities work centre.
- Select the Appointments work centre view.
- Open Appointment XXX (ABC represents the Appointment ID)
- Select Adapt and then Edit Master Layout.
- In the Overview tab, select the Add button above the Involved Parties pane.
- In the Role extension field, select Contacts.
- In the Involved Party extension field, open the Value Selection icon.
- Select the Show Advanced Filter button.
- Select the Organize Queries button.
- In the Related to Account column, tick the Visible checkbox.
- Select the Apply button.
- Now select Adapt and then End Layout Changes.
- Open the Value Selection once again for the Involved Parties.
- The Related to Account search query is still not visible.
Cause
This is the expected system behaviour as there is no Account maintained within the Appointment.
Resolution
The search query Related to Account will only become visible in the Contacts value selection if an Account is already maintained as an Involved Party in the Appointment. Without an Account, this query will not be displayed in the Contact object value selection.
Keywords
Related to Account, Search Query. Appointment , KBA , LOD-CRM-ACT , Activities , How To
Product
SAP Cloud for Customer core applications 1702 ; SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1708