SAP Knowledge Base Article - Public

2440195 - Item Type for a Service is missing in a Sales Order and the Service Master Data for selection

Symptom

You are not able to select an Item Type of a service e.g. Service - Time and Material in a sales order. The item type is not displayed in the drop down list.

When entering the ID manually one of the following errors occurs:

Products with item group Service - fixed price without actuals not supported

Products with item group Service - time and material not supported

Products with item group SERV - Service - fixed price not supported

Products with item group Service - time and material (project) not supported

Products with item group Service - fixed price (project) not supported

Further the respective Item Group e.g. SECO - Service - Time and Material is also not available for selection in the Sales tab in the Service Master Data.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Open sales order XYZ (XYZ represents the sales order ID).
  4. Navigate to the Items tab
  5. Select the respective service
  6. In the drop down list of the Item Type field in the Details sub tab the respective item type (in our example Service - Time and Material) is not displayed.

 

  1. Go to the Product and Service Portfolio work center.
  2. Select the Services view.
  3. Open service ABC.
  4. Navigate to the Sales tab.
  5. Select the Distribution Chain which is also maintained in the sales order XYZ.
  6. In the drop down list of the Item Group field in the Sales sub tab the respective item group (in our example SECO - Service - Time and Material) is not displayed.

 

 

Cause

The respective scoping questions is not active.

Resolution

  1. Go to the Business Configuration work center.
  2. Select the Implementation Project view.
  3. Select the respective implementation project.
  4. Click on the Edit Project Scope button.
  5. Navigate to the Scoping step.
  6. Expand the element path: Sales -> Product and Service Portfolio for Sales
    The scoping option Sell Services needs to be active.
  7. Navigate to the Questions step.
  8. Expand the element path: Sales -> Product and Service Portfolio for Sales -> Sell Services

    For Item Type SECO (Service - Time and Material) the following question needs to be active:
    Do you sell services for a price based on the actual time and material needed?

    For Item Type SERV (Service - Fixed price) the following question needs to be active:
    Do you sell or provide services for a fixed price, but track the actual time and materials needed for reporting purposes?

    For Item Type SEFL (Service - Fixed price without actuals) the following question needs to be active:
    Do you sell or provide services for a fixed price, but do not track the actual time and materials needed?

  9. For Project based services you need to expand the element path: Expand the element path: Sales -> Product and Service Portfolio for Sales -> Sell Project-Based Products and Services

    For Item Type PBTM (Service - time and material (project)) and  PBFP (Service - fixed price (project)) the following question needs to be active:
    You can sell project-based services.

Please note that if you want to activate Item Type SECO (Service - Time and Material) there is a dependency with the scoping element Service Confirmation. You need to ensure that Service Confirmation is activated in the Scoping step under the following path: Service -> Service and Repair (needs to be active) -> Service Confirmation (needs to be active)

Keywords

KBA , serv , sefl , service , seco , sales order , missing , AP-SLO , Sales Order Processing , How To

Product

SAP Business ByDesign all versions