SAP Knowledge Base Article - Public

2440382 - Request Type values are missing in Manage Workflow Requests

Symptom

Request Type values are missing in Manage Workflow Requests

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

Employee Central - Workflows

Reproducing the Issue

1. Navigate to Admin Center -> Manage Workflow Requests.

2. Click on the drop down for the field 'Request Type' -> There is only 'New Hire'

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Cause

The "Request type" drop down on "Manage workflow Requests" page will populate only those event reasons or request type which have been used to create any workflow

Resolution

It is expected behaviour as there are workflows triggered only for the event reason 'New Hire'.

NOTES:

You can distinguish between the Hardcoded Workflow Request Types from the ones created base on Organisation Requirement (Event Reasons)

native Request.png

This list of request type's is made up of event reasons for which a workflow has been used to create any workflow's, along with a set of hard coded workflow request types that are included in all EC enabled instances

These will be different from instance to instance, depending on the configuration of the system

 

For a full / current list with the technical names that you will find in Reorting/Analytics - please refer to the Implementing and Configuring Workflows handbook.

See Also

2545761 - List of Request Types Available in Manage Workflow Requests

2735704 - Manage Workflow Request: Request Type is more generic for MDF Workflow requests

Keywords

Workflows, Request Type, Manage Workflow Requests, ec, employee central,workflow , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core 1611