Symptom
A Workflow rule is created of type Messaging to send an SMS for object Activity Appointment. The notification has the Start/End Date Time of the Activity.
The SMS that is sent, default has the UTC timezone, not considering the preferences of the receipient or the default timezone of the tenant.
Environment
SAP Cloud for Customer.
Reproducing the Issue
- Go to the Administrator work center.
- Go to the Workflow Rules view.
- Open workflow rule ABC (ABC represents the workflow rule name).
- Under Enter Basic Data, find the type is Messaging.
- In the Define Actions guided activity, notice that Start Date Time is inserted in the text through a placeholder.
On the received message, notice the time in UTC time zone.
Cause
We are aware of the difference in behavior between Messaging and Email notifications. When replacing placeholders within Messaging notifications, the system does not consider the preferences of the recipient or the default time zone of the tenant.
Resolution
This is the system expected behaviour. We have planned to change this behavior in one of the future releases.
Keywords
sms, workflow rule, time zone, utc, time stamp , KBA , LOD-CRM-SC-MES , Messaging / SMS , How To