Symptom
When you try to activate an Org Unit after assigning a Service Agent to it, system throws below error messages:
DD.MM.YYYY to DD.MM.YYYY: employee(s) on org unit XYZ () must be below a cost center. It is also possible to flag the org unit to which the employee is assigned as a cost center.
DD.MM.YYYY to DD.MM.YYYY: employee(s) on org unit XYZ () must be below a reporting line unit. It is also possible to flag the org unit to which the employee is assigned as a reporting line unit.
DD.MM.YYYY to DD.MM.YYYY: employee(s) on org unit XYZ () must be below a business residence. It is also possible to flag the org unit to which the employee is assigned as a business residence.
Reproducing the Issue
- Go to Organizational Management work center.
- Select Edit Org Structures under Common Tasks.
- Add a Service Agent to the respective Org Unit
- Highlight the Org Unit.
- Check or Activate it.
Cause
The cause for the issue could be that you assign a Service Agent to an Org Unit which is not/under a Cost Center, Business Residence and Reporting Line Unit
Resolution
It is mandatory that you cannot assign a Service Agent/Employee to an Org Unit which is not (or under) a Cost Center, Business Residence and Reporting Line Unit.
Keywords
KBA , AP-PRP , Purchase Request Processing , How To