Symptom
You have a requirment to maintain Account Contact Relationship using External ID of Contact and Account in Data Workbench work center and system throws the below error message
External key, XYZ does not exist
Reproducing the Issue
1. Go to Data Workbench work center
2. Select Import view
3. Select Object as Account Contact Relationship
4. Select Next
5. Upload the required CSV template
Cause
The cause for the error is that External ID is used from creating Account Contact Relationship using Business System ID
Resolution
If the Business System ID is used for referring data from External System. You need to create Custom OData service for the Entity and maintain Scheme Code for the property ContactExternalKey in ID Mapping tab in properties section.
Keywords
KBA , LOD-CRM-EMP , Employee , How To