Symptom
When you are modifying Supplier name in master data, it is not reflecting in Shopping Cart
Reproducing the Issue
- Go to the Home work center.
- Select the Self Service view and open the Self-Services Overview subview.
- Open the Link Go Shopping (Advanced).
We see that the old address is displayed and not the modified address in the Shopping Cart.
Cause
Changes in master data will not be reflected in Shopping Cart if the modifications are done after the creation of the Shopping Cart.
If the Shopping Cart is copied from a Shopping Cart which has old address, then the system will not fetch the modified address.
Resolution
This is expected system behavior.
When you copy a shopping Cart, all the data in that Shopping Cart will be copied. Hence, the modifications done to the address will not be fetched.
Keywords
Shopping cart; Address displayed is incorrect; Supplier name in shopping cart , KBA , SRD-SRM-ESS , Employee Self-Service , How To