SAP Knowledge Base Article - Public

2443149 - Error while exporting a Canvas report from Learning

Symptom

Exported result of a Learning report in the Online Report Designer (ORD) is truncated with the following error message:

"Error:1 The result was truncated because the number of transferred bytes reached the set limit."

Error.jpg

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Learning

Reproducing the Issue

  1. Preview the report under concern - no issues >
  2. Export the report from the preview screen >
    or
    Create a report distributor bundle and export the report >
  3. The report's output is truncated with the error message >
  4. The behavior remains the same for CSV, XLS or XLSX output.

Cause

The Learning system has a limitation defined for the asynchronous storage (asyncStorageMaxSize) and this is defined in bytes. The error message indicates that the amount of data the report attempted to fetch has exceeded the aforementioned limit.

Another important point to be considered and noted:

  • If the “asyncStorageMaxSize” value is increased (e.g.: From 3 MB to 10 MB), the report is generated again and downloaded, and it is noticed that the file total size is smaller than the previous “asyncStorageMaxSize” value (3 MB) >

  • This is happening because each generated report size varies based on the types of the report format. E.g.: The “.csv” format consumes less memory compared to any other format, like the “.pdf” one >

  • It is not possible to predict how many records are going to be generated in the report based on the memory it consumes, as it depends on the number of columns, among other things. So, even though the “.csv” format is smaller than the previous “asyncStorageMaxSize” value (3 MB), other formats (“.pdf”) are greater than that, leading to the above-mentioned error.

Resolution

Option A: It is recommended to use filters for large-sized reports and hide duplicate rows when designing the filter.

Option B: If it is not possible to apply filters due to any business reasons, it would be necessary to increase the "asyncStorageMaxSize" setting to generate the full report. It is highly recommended the option A, since increasing the "asyncStorageMaxSize" value might result in latency/timeout issues while executing the Learning reports in ORD.

  1. Access the Learning admin side > System Administration >
  2. Configuration > System Configuration > REPORT_SYSTEM >
  3. Search for the "asyncStorageMaxSize" entry and adjust it > Apply Changes.

See Also

2286760 - LMS reports are aborting

Troubleshooting Learning Fields for ORD

Keywords

export, ord, lms, learning, learning, Learning - Report is truncated - Error:1 The result was truncated because the number of transferred bytes reached the set limit, asyncStorageMaxSize , KBA , LOD-SF-ANA-ORD , Online Report Designer , LOD-SF-LMS-REP , Reporting Data , Problem

Product

SAP SuccessFactors HCM suite all versions ; SAP SuccessFactors Learning all versions

Attachments

config1.jpg
config2.jpg
Error.jpg