Symptom
Error occurs on change of a field in Benefit Employee Claim Screen.
Environment
Successfactors - Employee Central Global Benefits
Reproducing the Issue
- Navigate to the Employee's Benefit Screen.
- Click on 'Claim' for the Benefit.
- Change value of 'Treatment Name' (custom field) and an application error occurs.
Cause
There is a rule assigned to the 'Treatment Name' field. The rule is setting an value to the 'Bill Amount' field. The 'Bill Amount' field is a standard 'amount' field in the object definition 'BenefitFuelReimbursementClaimDetail'.
The standard 'Amount' field in this object has an already defined logic in the backend to sum up all the values and set to the Total Claim Amount field (In Benefit Claim Screen).
Since, there is an already defined logic for the Amount field, you cannot have a rule to set a value to this field.
Resolution
The workaround is to create a custom field named 'Amount' and use that field in the rule to set the value.
Also, please note that the custom field will not have a logic to calculate/sum all the amount values from different rows. Such a requirement is not supported currently. You will need to manually enter the value to the standard 'Amount' field.
Keywords
Global Benefit Benefit BenefitFuelReimbursementDetailAmountOnChangeProcessor Claim Reimbursement Benefit Employee Claim isEmpty 561f281e567132e3a02290e7a8fedbe0cd20ab35 , KBA , LOD-SF-EC-GBF , Global Benefits , Problem