SAP Knowledge Base Article - Public

2443672 - Error while opening CustomerObjectReferences from SDK PDI

Symptom

Error while opening CustomerObjectReferences from Cloud Application Studio.

Reproducing the Issue

  1. Login to Cloud Application Studio.
  2. Open Solution.
  3. Open CustomerObjectReferences.ref file.
  4. Error appears.

Column 'boName, noNamespace, noNodeName, fieldName, fieldType' is constrained to be unique. Value 'Opportunity, http://sap.com/xi/AP/CRM/Global, Root, OppAllProductcategory, List(30)' is already present.

CD2.png

Cause

This error appears when you have more than one KUT field with the same name and the same data type.

Resolution

You can find business object, Node name, FieldName and FieldType from the error message.

For example :

BO : Opportunity
Node : Root
Field : OppAllProductcategory
Type : List(30)

Delete one KUT field from Edit Master Layout and re-activate the solution to resolve this error.

Keywords

KBA , AP-RC-BDS-BO , ByDesign Studio BO definition/generation , How To

Product

SAP Hybris Cloud for Customer add-ins 1605 ; SAP Hybris Cloud for Customer add-ins 1608 ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711 ; SAP Sales OnDemand 1.0 ; SAP Sales OnDemand 2.0 ; SAP Sales OnDemand 4.0