Symptom
Error while opening CustomerObjectReferences from Cloud Application Studio.
Reproducing the Issue
- Login to Cloud Application Studio.
- Open Solution.
- Open CustomerObjectReferences.ref file.
- Error appears.
Column 'boName, noNamespace, noNodeName, fieldName, fieldType' is constrained to be unique. Value 'Opportunity, http://sap.com/xi/AP/CRM/Global, Root, OppAllProductcategory, List(30)' is already present.
Cause
This error appears when you have more than one KUT field with the same name and the same data type.
Resolution
You can find business object, Node name, FieldName and FieldType from the error message.
For example :
BO : Opportunity
Node : Root
Field : OppAllProductcategory
Type : List(30)
Delete one KUT field from Edit Master Layout and re-activate the solution to resolve this error.
Keywords
KBA , SRD-CC , Cross Components , How To
Product
SAP Hybris Cloud for Customer add-ins 1605 ; SAP Hybris Cloud for Customer add-ins 1608 ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711 ; SAP Sales OnDemand 1.0 ; SAP Sales OnDemand 2.0 ; SAP Sales OnDemand 4.0