Symptom
You cannot Add an ID field to the Task List through Personalize or Adaption Mode.
Reproducing the Issue
To Reproduce the issue, follow the steps below:
- Navigate to Work Center "Activity Planner".
- Move to View "Plans".
- Select an Activity Plan ABC.
- Move to the "Tasks" Facet of the plan.
- Observe there is no column for ID.
- Click Personalize. Hover over a column to add fields.
- Observe the fields available.
- Repeat steps 6 & 7 for Edit Master Layout function.
ID column is not available to be added to the table.
Cause
This is Expected System Behaviour.
Resolution
The activity plan solely acts like a template.
There is no ID maintenance for this.
Depending on the routing rules setup, the plan will add the tasks defined to a document. Example: adding tasks into a Visit.
The tasks will then carry an ID in the document.
Keywords
KBA , LOD-CRM-ACT , Activities , How To
Product
SAP Cloud for Customer 1211 ; SAP Cloud for Customer 1302 ; SAP Cloud for Customer 1305 ; SAP Cloud for Customer 1308 ; SAP Cloud for Customer 1311 ; SAP Cloud for Customer 1402 ; SAP Cloud for Customer 1405 ; SAP Cloud for Customer 1408 ; SAP Cloud for Customer 1411 ; SAP Cloud for Customer 1502 ; SAP Cloud for Customer 1505 ; SAP Cloud for Customer 1508 ; SAP Cloud for Customer 1511 ; SAP Cloud for Customer 1602 ; SAP Cloud for Sales 3.0 ; SAP Hybris Cloud for Customer add-ins 1605 ; SAP Hybris Cloud for Customer add-ins 1608 ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711 ; SAP Sales OnDemand 1.0 ; SAP Sales OnDemand 2.0 ; SAP Sales OnDemand 4.0