SAP Knowledge Base Article - Public

2444496 - Unable to Create Communication Arrangement for the Webservice Created via Custom Object Builder

Symptom

You are unable to find the communication scenario to create communication arrangement for the webservice created via custom object builder.

Reproducing the Issue

  1. Login to C4C tenant.
  2. Navigate to Administrator work center.
  3. Select the link for Custom Object Builder.
  4. Create a custom business object based on your requirement.
  5. Select the checkbox for Webservice the Save and Publish.

The work center and webservice based on the custom business object will be created automatically.

  1. Navigate to Application and User Mangement work center.
  2. Select Communication Arrangement View.
  3. Click on New button.
  4. You will not be able to find a communication scenario for the webservice created.

Cause

There is no need of creating communication arrangement for the webservices which has been created via custom object builder, and that is the reason why you will not be able to find the communication scenario in the list.

Resolution

Once the Custom Business Object is activated with the webservice, automatically the relevant files will be created for the webservice.

You just have to assign the work center view name generated to your user by following the below mentioned steps:

  1. Navigate to Application and User Mangement work center.
  2. Go to Business User View.
  3. Find your User and click on Edit Access Rights.
  4. Select the Work Center and View Assignments tab.
  5. Find the work center view created for the custom business object you have created.
  6. Select the check box.
  7. Click on Save.

You will be able to consume the webservice created now.

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711