Symptom
When viewing the Country Specific jobInfo elements in Business Configuration UI (BCUI), we noticed that the list of Business Rules that are attributed to the element (onSave, onInit, saveAlert, onView, onPostSave) have been copied from the globa jobInfo element configuration.
Global Job Info Configuration
Country Specific Job Info Configuration
Environment
Employee Central 2.0
Business Configuration UI
Cause
This is currently expected behaviour. The Business Configuration UI Synchronization framework is hard-coded to copy the jobInfo element rules from the Succession Data Model, to the Country Specific jobInfo element configuration in BCUI unpon importing the Country Specific Succession Data Model.
NOTE: The rules that are copied are only displayed in the BCUI Country Specific jobInfo element configuration page, but they are not copied to the Country Specific Succession Data Model xml configuration - therefore they do not get triggered from the Country Specific Job Info configuration, only from them being present in the Global Job Info element configuration
Resolution
This defect was fixed with the 1805 release. Now, the Business Rules that are saved against the global element, will not display against the country specific element in Manage Business Configuration (BCUI).
If you still see global rules saved in a country specific element, please export and import the Country-Specific Succession Data Model and then wait 5 minutes for the Synchronize Business Configuration job to complete, and this will clean up the BCUI.
Keywords
ECT-62774, bcui, country-specific, rules, display, country specific , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem