SAP Knowledge Base Article - Public

2446657 - Error When User Confirms a Waitlist for a Class

Symptom

When registering for a waitlisted Class and selecting Confirm, error message is displayed (main error messages below):

com.plateausystems.elms.util.process.ElmsProcessException: com.plateausystems.elms.util.process.ElmsWorkflowException: root cause: pwsEnrollStudent failed

Caused by: com.plateausystems.elms.util.process.ElmsWorkflowException: root cause: pwsEnrollStudent failed

Caused by: com.plateausystems.elms.util.helper.ElmsUpdateException: pwsEnrollStudent failed

Caused by: com.plateausystems.elms.util.helper.ElmsNotifyException: doSendEmailNotification(): sender e-mail address not specified

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. User navigates to Learning and their My Learning Assignments tile
  2. Select Register Now from the ILT item
  3. Select Waitlist, and Confirm
  4. Error is generated 

Cause

The cause for this is that the Application Notification User e-mail is missing

System Administration -> Configuration -> Global Application Settings -> Mail tab will be missing and the system is not able to allow the User to waitlist, since the e-mail cannot be generated.

Resolution

The resolution is to maintain a value for the User notification e-mail as per the screen shot below and then try to perform the action to be waitlisted in the schedule offering as the User.

email tab.jpg

Once a value is entered in the above field, user will not see the error.

Keywords

Waitlist, Class, Error when registering for a Schedule offering, pwsEnrollStudent failed, doSendEmailNotification(), sender e-mail address not specified , KBA , LOD-SF-LMS-NOT , Notifications , Problem

Product

SAP SuccessFactors Learning all versions