Symptom
National ID card Type field is not visible in the system.
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central - Personal Information
Cause
This is due to one of the below configuration issues:
- Global Info element is configured in Country specific succession data model(CSF) and not in Succession data model(SDM) .Elements configured in CSF data model must be added in SDM too.
- No format-groups are defined in the CSF succession data model. The National ID Card type field fetches values from the format-groups configured in the CSF data model. If no format-group is defined the field will not be displayed. Refer Employee Central Master Data Models.
- The Sections are not populated for HRIS Element > HRIS Fields while for jobInfo countries are populated.
- There is a picklist defined in BCUI/XML for nationalIDCard.country
Resolution
- Enable global info element in Succession Data Model.
- Configure format-groups in the CSF Data Model
- Populate the sections for jobInfo > HRIS Fields.
- Remove the picklist from nationalIDCard.country - guide reference.
See Also
Keywords
National Id card, National ID, Succession Data Model, Country Specific Succession Data Model, card-type, country. , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , LOD-SF-EC , Employee Central , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions