Symptom
- EC to EP name sync is inconsistent.
- Employee name does not sync correctly to the Quick Card, even though the name change has been made in EC and the sync has run correctly to EP.
Environment
- SAP SuccessFactors HCM Cloud
- Employee Central
Reproducing the Issue
- Search for a user with First Name and Last Name in Action search box.
- Notice that the search result displays a different First Name and Last Name.
- In Perosnal Information, the user has the First Name and Last Name that was typed in the Action search box.
Cause
A combination of the following may lead to this issue:
- Name Formatting is enabled
- Though Name Formatting is enabled, formal-name field in Personal Information is not enabled.
- The impacted user's First Name and Last Name were updated.
- This caused the values not to get synced to formal-name field
- The formal-name field still has the previous values.
- When Name Format is enabled, users are searched by formal-name field value in the action search bar, even though formal-name is not enabled.
- Since this field is not enabled, existing values do not get updated.
Resolution
- Enable the field formal-name from Admin Centre -> Manage Business Configurations -> personalInformation.
- This is needed because the feature Name Format is enabled in the instance.
- Once you enable this field and Save it in Manage Business Configurations, make some dummy change in the Personal Information of the user.
- This should sync the First Name and Last Name to formal-name field.
- If several users are impacted you may consider importing Personal Information for all of them or run a Full HRIS Sync - reference KBA 2080065 - What is a Full HRIS Sync? - Employee Central
See Also
Keywords
SuccessFactors , Success Factors , SF , EC , HRIS , name format , formal name , ECT 68754 , KBA , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-EC , Employee Central , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions