SAP Knowledge Base Article - Public

2448494 - Interview Central without configuring competencies - Recruiting Management

Symptom

Sometimes customers do not want to use Competencies, but they still want to use the Interview Central feature of Recruiting. When creating an Interview Assessment for a Job Requisition without competencies configured, below are the points observed:

  • We receive a pop-up with a warning message for not having configured any competency.
  • The interviewer can still provide an overall Recommended/Not Recommended on the applicant, add overall comments and possibly attach interview notes/feedback. However, the comments and the Recommended/Not Recommended are not visible to the recruiter once he clicks on “View Candidate ratings”. 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Login to SF as the interviewer for an applicant in a requisition.
  2. Go to Recruiting →Interview Central
  3. For the applicant in the requisition, click on 'Rate Now'. If competencies are not configured for the requisition, an error message shows up: "Error: the competencies are not properly configured on the job requisition template. Please contact your system administrator for assistance":

IV Central 1.PNG

  1. The interviewer can provide an overall Recommended or Not Recommended on the applicant, add overall comments and attach interview notes:

IVCentralb2211.png

  1. Login to SF as the recruiter of this requisition.
  2. In the candidate summary for this requisition, click on View Candidates Ratings. The overall rating and the comments are not visible; only the interview notes can be seen:

ViewCandidateRatingsb2211.png

Cause

This is an expected product behaviour. If there are no competencies configured in the requisition, the user receives an error pop up upon using the Interview Assessment form. This error pop-up cannot be disabled; only the addition of competencies on the requisition will avoid this pop up.

The customer would need to create at least one competency to get this functionality working properly.

If competencies or capabilities have been added then the issue is caused by a character limit of 255 characters being breached, competencies and capabilities have a limit of 255 characters for Job Profile in Job Requisitions.

Resolution

If the customer is not ready to configure competencies in the requisition, the above behaviour is expected.

A suggested workaround will be to create a competency which would fit any interview. It doesn't need to be a "real" competency, just a dummy one. In this way, you can avoid the error when using Interview Central. Also, the recruiter will be able to view the overall ratings, comments and notes when accessing the candidate's ratings.

Should the issue be caused by competencies having more than 255 characters, please reduce the characters to below 255 characters.

Note: If you have competencies configured, please provide a rating for them so that Users can see the competency & recommendation rating in View Candidate Ratings.

See Also

3085316 - Application Error received when Accessing Interview Feedback

Keywords

Error, Competencies, Configured, Job, Requisition, Template, Interview, Central, Candidate, Ratings , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem

Product

SAP SuccessFactors Recruiting all versions