SAP Knowledge Base Article - Public

2449702 - Alert/Workflow Notification is not being received by all the CC Roles

Symptom

EC Alert Notification/Workflow notification is not being received to all the emails in CC

Environment

Successfactors - Employee Central

Reproducing the Issue

Alert is configured but the emails configured under the CC are not getting email notification.

Cause

  • Single Recipient is configured in Provisioning. This will send all of the email notifications to the email that is configured in the Single Recipient Email.
  • The CC Role user does not have an email maintained in Basic User Data
  • The CC Role configured is not supported for the Alert Type (if it is MDF Alerts)
  • Either the initiator or the recipient does not have a business Email Address

Resolution

CC - An email is sent to notify the recipient of workflow completion. Once a workflow is completed the named users in the CC role will be sent a notification email of the workflow completion. Refer to:2080108 - Workflow Role Types - Employee Central

1. Single Recipient

    1. Go to Admin Center
    2. Search for Manage Email Notifications (if you do not find the tool, make sure that the permissions 'Admin Center Permissions > Manage Email Notifications' was given)
    3. Here you will find where to configure Single Recipient

     Please refer to 2087890 - Top Reasons Why Email Notifications are Not Sent or Received. Basic Troubleshooting - HXM Suite

    2. User does not have valid Email Address maintained

    1. Go to Admin Center > Employee Export > Export Users
    2. Check that the user in question has a valid email address in the "email" column 

    3. The CC Role configured is not supported for the Alert Type (if it is MDF Alerts)

    If this is regarding MDF alerts, only certain Roles are supported for CC Role. Please refer to article 2532558 - How To Configure MDF Alerts and Notifications for MDF Objects

    4. Either the initiator or the recipient does not have a business Email Address

    • All participants involved in the workflow process, Recipient, Initiator, and/or last step approver has to have a unique value in the Business Email address field
      • Depending on the workflow that can be the subject user, the admin or an API user if the workfow is triggerd by an integration process
    • This applies to Alert workflows as well

    5. 'Email Notification' option under 'Change User Email Notification' for affected user is not enabled

    If user is list of users who opted out from notifications through mail with configuration on Change User Email Notification tool -> Email Notification, then it will affect all mail notifications to the user including CC notifications as expected. Please refer to article 2087440 - Disabling Email Notifications For One or More Users for an Instance - SAP for Me for more details.

    FAQ - Additional Information

    Q) Where can I get Guide?

    A) Guide: Employee Central Workflows: Implementation and Administration

    Chapter: Setting Up Batch Reminders for Stalled Workflows with a Recurring Job

    See Also

    • 2087440 - Disabling Email Notifications For One or More Users for an Instance
    • 2087890 - Top Reasons Why Email Notifications are Not Sent or Received. Basic Troubleshooting - HXM Suite 
    • 2358563 - Workflow Email not being sent to all cc recipients
    • 2446500 - How is the Recipients local Determined for Workflow Emails and Alerts and Notifications
    • 2632511 - Workflow Participant Receives two Email Notifications for the Same Workflow
    • 2087739 - Single Sender and Single Recipient | How They Work and How to Set Them Up
    • 2080108 - Workflow Role Types - Employee Central 

    Keywords

    Alerts, Notification, Workflow, Email, Single Recipient, Recipient. ec, mdf, change Email Notification setting, CC,Workflow notification, no email address, EmpCentrl, no notifications, workflow triggered improperly, success factors, no alert , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , LOD-SF-EC , Employee Central , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem

    Product

    SAP SuccessFactors HCM Suite all versions