Symptom
A workflow rule that contains a condition with the compare operator Matches Pattern is not getting triggered.
Reproducing the Issue
Pre-Requisite:
A workflow Rule that contains a condition with the compare operator Matches Pattern.
Example:
Business Object: Accounts
Timing: On every Save
Condition:
Field: Additional Name
Compare Operator: Matches Pattern
With: Value
Value: 123
Defined Action: E-Mail
Reproducing the issue:
- Go to the Customers work center.
- Select the Accounts view.
- Open account XYZ (XYZ represents the account ID).
- Select the Edit button.
- Enter the value Test123 in the field Additional Name.
- Select the Save button.
The workflow rule is not getting triggered. Only when the value in the field exactly matches the value in the workflow rule, it is getting triggered.
Cause
This is the expected system behaviour in SAP Hybris Cloud for Customer.
Resolution
In order for the change to trigger the workflow rule, the value maintained in the rule needs to be entered with an * in front and behind the value (eg *123*).
Keywords
KBA , LOD-CRM-EMP , Employee , How To