Symptom
You are trying to add an employee to a project task in the past but the employee is no longer part of the company on the day of the change.
When entering the Employee's name, you get the message No records found in the Value selection. When you add the Employee's name directly and press enter, you get the error message Employee XYZ does not exist.
Reproducing the Issue
- Go to Project Management work center.
- Go to Projects view.
- Show all.
- Find ABC (ABC represents the Project ID).
- Edit - Project Plan.
- Go to Work tab.
- Add a new line.
- Enter XYZ in Team member field (XYZ represents the Employee's name).
You get the error message Employee XYZ does not exist.
Cause
When you enter an employee's name or a part of it, the system will search for a valid employee record for the current date (today). This search is performed regardless of the dates associated with the project task or service. It is important to note that if the employee is not employed on the current date, the system will not find them, as this is the expected behavior.
Resolution
You enter the Employee ID rather than the name to assign that employee to the task and service. The reason for this is that with the Employee ID, the checks are fulfilled using the project start date and not the current date.
Keywords
Invalid employee error; employee in project; No records found; , KBA , AP-PRO , Project Processing , How To