SAP Knowledge Base Article - Public

2452922 - Error when Uploading Contacts to a Target Group Via Microsoft Excel: "Adding member not possible; contact XYZ is not an individual"

Symptom

When trying to upload Contacts into a Target group, the following error message is displayed: "Adding member not possible; contact XYZ is not an individual."

Environment

SAP Cloud for Customer

Reproducing the Issue

Pre-Requisite:

The AddOn for Microsoft Excel needs to be downloaded and installed.

  1. Go to the Marketing work center.
  2. Select the Target Groups view.
  3. Select the Actions icon.
  4. Select New from Microsoft Excel.
  5. Select Download and open the template.
  6. Maintain Contact XYZ (XYZ represents the ID of the contact).
  7. Save the changes in the template.
  8. Switch to the facet SAP Hybris Cloud For Customer.
  9. Select Logon and enter the URL and the user credentials for the tenant the target group should be uploaded to.
  10. Select Save Data to.

The following error message appears:

"Adding member not possible; contact XYZ is not an individual."

In SAP Cloud for Customer the Target Group was created, but no members are displayed in the group.

Cause

This is the expected system behaviour in SAP Hybris Cloud for Customer.

Resolution

To add a contact to a Target Group via Microsoft Excel, it is necessary to provide both the Contact ID and the ID of the Associated Account in the template for the Target Group to be created.

Providing only the contact ID is not sufficient.

When adding an Account or an Individual Customer to a Target Group via Microsoft Excel, it is sufficient to maintain only the Account ID / Contact ID.

 

Keywords

KBA , LOD-LE-MKT , Marketing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions