Symptom
Standard fields in Basic Information of Talent Search v2 show in alphabetical order but one of the fields doesn't follow alphabetical order & shows at the top in the drop-down list.
Environment
SuccessFactors BIZX: Talent Search v2
Reproducing the Issue
1: Go to Talent Search v2
2: Click on the drop down of Basic Information, one the fields is not following alphabetical order as below:
Cause
The field not following alphabetical order wouldn't be correctly defined in Succession data model xml.
Resolution
Clients open an case with Cloud Product Support or contact their implementation partner & ask them to modify data model xml as below:
Initial configuration:
<userinfo-element id="employeeClass" type="varchar" required="false">
<label> Nature of Contract</label> # There is an extra space after label tag (<label>) which is causing the field to show at the top.
</userinfo-element>
Modification:
<userinfo-element id="employeeClass" type="varchar" required="false">
<label>Nature of Contract</label> # Remove extra space after label tag and import data model xml
</userinfo-element>
Keywords
incorrect order of field in Basic Information, order of field in Talent Search v2, Basic Information, Talent Search , KBA , LOD-SF-SCM-TS , Talent Search , Problem