Symptom
You are using Routes to create visits with recurrence and the Visit-By Date field is not showing the information expected.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Visits work center;
- Select Routes view;
- Click in New button;
- Click in Save and Open in the New Route pop-op open;
- Click in Add in the Proposed Visits pane;
- Click in the magnify glass icon to show advanced search in the Accounts pop-up;
- Check the Add Recurrence checkbox;
- Select Account ABC (ABC represents ID of an Account);
- Click in Add to Date button;
- Select Date DEF for this Visit (DEF represents a date for the visit);
- Repeat steps 5-9 for account GHI (GHI represents ID of an Account);
You notice different information than previously selected for on date of the Proposed Visits.
Cause
When you enter accounts for proposed visits in routes, the system calculates visit recurrence using different sources. In addition to using the Visit Before field from the account or customer, the solution also uses recommended frequency in the sales data for visits. Therefore, when you select an account for a proposed visit, if the solution calculates different recurrence intervals from both sources the recurrence that is based on the sales data is the only one that appears in the result list.
Resolution
This is the current system behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Visit By Date, Visits, route , KBA , LOD-CRM-ACT-VST , Visit Planning , How To