SAP Knowledge Base Article - Public

2453782 - For A Sales Kit Item The Following Error Occurs In A Return: Item XX: Mandatory List Price Missing For The Price Calculation

Symptom

When creating a customer return based on a sales order with kit items, the system displays the following error for the kit sub items:

"Item XX: Mandatory List Price missing for the price calculation".

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Returns view.
  3. Open return XYZ (XYZ represents the ID of the return).
  4. The following error occurs for a sales kit - sub item:
    "Item XX: Mandatory List Price missing for the price calculation".

Cause

You created a Return for a Sales Kit but instead of just selecting the Sales Kit – Header Item, you selected the Sales Kit – Header Item and also all of the Sales Kit – Sub Items.

When you create a Return for a Kit Item you need to just select the Sales Kit – Header Item in the first step in the New Customer Return Notification. The Sales Kit – Sub Items will then automatically be pulled as you can see in the second step.

If you select the Sales Kit – Header Item and the Sales Kit – Sub Items in the first step of the New Customer Return Notification, the system determines Sales Kit – Header Item and populates the Sales Kit – Sub Items automatically and in addition the manually selected Sub Items are added as normal items in addition. This means that for these normal items the system expects a List Price in the created Return.

Resolution

To solve the issue you need to first ensure that the Return is consistent and then cancel the Return.

  1. Go to the Sales Orders work center.
  2. Select the Returns view.
  3. Open return XYZ.
  4. Navigate to the Pricing tab.
  5. Select the respective item and click the Expand button.
  6. Click Add Row.
  7. In the drop down list for the Price Component select the option List Price.
  8. Maintain the corresponding amount.

Now cancel the Return via the Inbound Delivery and also cancel the Inbound Delivery Notification.

You can then create a New Customer Return Notification, Inbound Delivery and Return. Please ensure that you only select the Sales Kit Header in the first step of the New Customer Return Notification.

See Also

KBA 2936830 - How to Cancel a Customer Return

SAP Help Document: Kits Process Flow

Keywords

Customer Return, Sales Kit, Mandatory list price missing , KBA , SRD-CRM-RET , Returns , Problem

Product

SAP Business ByDesign all versions