SAP Knowledge Base Article - Public

2453791 - Scheduled Sales Order Status still In Process / Open

Symptom

Sales order is in status In Process but you expect it to be in status Completed.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Open sales order ABC (ABC represents the sales order number).
  4. Navigate to the Items tab.
  5. Select line item XX (XX represents the line item number).
  6. Line item XX is linked to project XYZ (XYZ represents the number of the project).
  7. The Invoice Status for the line item is in status Finished and all invoicing has been completed for this sales order.

Therefore you would expect the sales order ABC to be in status Completed but the status is In Process

Cause

Case 1.

Manually created Project Invoice Requests do not change status of scheduling items and Sales Order.

Case 2.

The automatic finish invoicing on a Sales Order item works only for Fixed Price Items. In case of Time and Material the Sales Order will be in In Process status

In case of Service - time and material (project) item type, this is not the case reason being - Service - time and material (project) items type are based on actuals. It is not a fixed amount expected. The actuals could be equal or more than the planned amount in the Sales Order. Because of this reason, Service - time and material (project) items type are not completed automatically. Once all the actuals are there, you can do the finish invoicing manually.

A sales order can be only in status Completed if both statuses are set to Finished. The Invoice Status is set to finished when all invoicing for the sales order has been completed. The Delivery Status in project based Invoicing can be set to finish when the project is completed.

Case 3.

You have open invoice schedules in the Sales Order and therefore the Change Status button in the Customer Invoicing work center -> Project Invoicing view and Sales Orders sub view is disabled. Hence you are not able to select the Finish Invoicing option.

Resolution

Case 1.

Cancel the manually created Project Invoice Request and retrigger the schedule the system will created the scheduled invoice the sales order status becomes consistent.

If you intend to keep the manually created project invoice request then please follow the case to resolution.

Case 2.

In order to complete the sales order ABC you need to change the delivery status of the sales order to finished by changing status of the project to Complete or to Complete and Close.

  1. Go to the Project Management work center.
  2. Select the Projects view.
  3. Open project XYZ via the Edit -> Project Plan button.
  4. Select the Basic Data sub tab.
  5. In the Project Status field select the Complete or Complete and Close option.

You can finish the invoice status of the sales order as follows:

  1. Go to the Customer Invoicing work center.
  2. Select the Project Invoicing view.
  3. Select the Sales Orders sub view.
  4. Select sales order ABC.
  5. Press the Change Status button and select the Finish Invoicing button.

The Status of the related sales order ABC will now change to Completed.

Case 3.

In order to select the Finish Invoicing option you need to ensure that all Invoice Schedules in the Sales Order are Invoiced.
You can cancel any open Invoice Schedules in the Sales Order via the Cancel open dates option.

Using this action you can cancel all invoice schedule items that are in open status.
If an unreleased invoice document exists for any open date then corresponding invoice request will change to status “With Conflict” and you can then cancel the invoice document. (See also KBA 2776630 - Customer Invoice Cannot be Released due to a Conflict detected in the Scheduled Invoice Request)

you can proceed as follows:

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Open Sales Order XYZ (XYZ represents the ID of the Sales Order).
  4. Navigate to the Pricing and Invoicing tab and the Invoice Schedule sub tab.
  5. Select the respective Item.
  6. Click on the Action button and select the Cancel open dates option.

 

See Also

2776630 - Customer Invoice Cannot be Released due to a Conflict detected in the Scheduled Invoice Request

Keywords

Invoice Status; Status; Completed; Invoice Schedule; Cancel open dates , KBA , AP-SLO-SO , Sales Order , How To

Product

SAP Business ByDesign all versions