Symptom
Live Activity pane displays Unknown Caller when a call is received from Employee.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: Live Activity configuration has been completed and Employee has required data maintained in the system.
- Log in to C4C and open CTI Adapter.
- Simulate a call with number Dialing From as phone number of employee ABC (ABC represents employee's ID).
- In Live Activity pane, caller appears as Unknown Caller.
Cause
You have not configured Administrator settings for enabling Employee search.
Resolution
Follow the below steps to enable the same:
- Go to the Administrator work center.
- Go to the Service and Social view.
- Open the Live Activity Configuration link under Communication Channels.
- In the Fiori Client Settings, Search Objects, click Add button.
- Select Employees in the Add Search Object popup.
- Click Add button.
- Click Save and Close button.
See Also
KBA 2890012 - Fields That Are Set to Visible in The Live Activity Center Are Not Displayed
KBA 2621049 - How to set up CTI to Have Names Displayed for Individual Customers, Accounts and Contacts as well as Employees When Receiving Phone Calls.
Help Portal: Solution Guide for SAP Service Cloud - Chat Communication Channel
Keywords
Employee, live activity, CTI, call, simulate, communication channels, unknown caller, CTI adapter, phone call, activity, chat, search, fields, search object, , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-LA , Live Activity , How To