Symptom
Email notification “ApprovalProcessRequestDenied” or "ApprovalProcessRequestApproved" is not being send to users when registering for a Class.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Attach an Approval Process to a Class
- As a user search for the Class and request for the Approval to be registered into the offering
- As the approver, approve or deny the user's request to be enrolled into the class
- See that the email that the user should receive once the request is approved/denied based on the ApprovalProcessRequestApproved/ApprovalProcessRequestDenied template is not triggered
Cause
The cause for this is that there is a setting under System Administration > Configuration > Global Application Settings that is checked to supress this notification.
Below is the screen shot which shows the setting checked which is why the email does not get sent to the user.
Resolution
The resolution for this is to uncheck the setting highlighted above and then replicate the scenario.
Once this setting is unchecked, the user will start to receive the email as per the ApprovalProcessRequestApproved and ApprovalProcessRequestDenied notification template.
See Also
User Assistance documentation: Learning Approval Process Global Application Settings
Keywords
ApprovalProcessRequestDenied, ApprovalProcessRequestApproved, Approval process, SAP, SF, LMS, deny, notification, email, class approval notification not received , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS , Learning Management System , Problem