SAP Knowledge Base Article - Public

2454073 - ApprovalProcessRequestApproved email not sent to the user

Symptom

The ApprovalProcessRequestApproved notification is not being sent to the users.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Attach an approval process to a class
  2. As a user search for the class and request for the approval to be registered into the class
  3. As the approver, approve the user's request to be enrolled into the class
  4. See that the email that the user should receive once the request is approved based on the ApprovalProcessRequestApproved notification template is not triggered.

Cause

This can happen due to a setting in LMS under System Administration > Configuration > Global Application Settings, that is checked to suppress this notification.

Below is the image which shows the setting checked which is why the email does not get sent to the user:

Capture.PNG

Resolution

Uncheck the setting highlighted above and then replicate the scenario again.

Once this setting is unchecked, the user will receive the email as per the ApprovalProcessRequestApproved notification template.

Keywords

lms, learning, sf, successfactors, approval, process, notification, ApprovalProcessRequestApproved, not, triggered, suppress, email, setting, registration , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS-TAP , Approvals , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions