SAP Knowledge Base Article - Public

2454073 - ApprovalProcessRequestApproved email not sent to the user - LMS

Symptom

We are having problems with “ApprovalProcessRequestApproved” notification. It is not being send to users

Environment

SuccessFactors Learning

Learning Management System

Reproducing the Issue

1. Attach an Approval Process to the Schedule offering.

2. As a user search for the Schedule offering and request for the Approval to be registered into the offering.

3. As the approver , approve the user's request to be enrolled into the offering.

4. See that the Email that the user should receive once the request is approved based on the ApprovalProcessRequestApproved is not triggered.

Cause

The cause for this is that there is a setting under System Admin->Configuration->Global variables that is checked to supress this notification.

Below is the screen shot which shows the setting checked which is why the email does not get sent to the user.

Capture.PNG

Resolution

The resolution for this is to uncheck the setting highlighted above and then replicate the scenario.

Once this setting is unchecked, the user will receive the email as per the ApprovalProcessRequestApproved notification template

Keywords

ApprovalProcessRequestApproved, Approval process , KBA , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions