Symptom
- Application error when editing People Profile Block/s in Configure People Profile Page
- Fields are not displayed as configured in People profile (Specially in Hire Page)
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
Successfactors Employee Central People Profile
Reproducing the Issue
1. Error when configuring
- Go to Admin Center > Configure People Profile Page.
- Edit one of the blocks (in this case editing the Employment Details) by clicking the here button.
- Application Error Occurs:
2. Fields not displayed as expected.
- Field not displayed as configured in Configure People Profile OR
- For example the display or the order of fields in Production is different from Test
Cause
People Profile Block not Synchronized.
You need to refresh the block.
Resolution
In one instance the resolution to this issue is to re-add the block to the configure people profile page.
To remove and add back the block to the configure people profile page you need to do the following.
1. Go to Admin Center> Configure People Profile.
2. Select the Block wherein you are experiencing the issue.
3. Click on the Remove button and Save the block.
4. Once saved, go back again to Configure People Profile Page and add back the deleted block.
NOTE: If doing the above steps does not resolve the issue please create a support ticket providing the following.
1. Company ID
2. Username that has Support Access
3. Steps to reproduce the issue.
4. Application error (text format not screenshot)
Keywords
Application Error in Configure People Profile, ECT-68623, Order of fields, Fields alignment, Fields display , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , LOD-SF-EC , Employee Central , Problem