SAP Knowledge Base Article - Public

2456947 - Item not showing on the "Completed Items" tab after using the "Add Learning History Tool"

Symptom

After an administrator utilizes the "Add Learning History with Finance" or the "Add Learning History for Multiple Courses" and it states that the completion was given to the user, the completion cannot be seen in the "Completed Items" tab of the user record.

Environment

SAP SuccessFactors Learning

Cause

The item has a required survey to be completed before item completion be given.

Resolution

  1. Go to Learning Activities > Items > Search for the Item that was used in the "Add Learning History" tool >
  2. Access the "Surveys" tab >
  3. If the "Course Feedback Survey" has the "Required for Item Completion" selected, the user must complete the survey on their learning plan. Then, the item completion should appear in the learning history.

If the survey on the item level is removed or the "Required for Item Completion" box is unchecked, the user will receive completion. This will impact all users that have the item assigned.

It's also possible to go to the user record > "Surveys" tab and manually delete the specific survey.

As long as there's a required survey associated with the item, there will be no standard tool or method to check the pending learning history. The only way to export the pending learning history is by creating a custom report to export the "PA_PENDING_CPNT_EVTHST" table data.

See Also

2379690 - Custom Report Development and Support - SAP SuccessFactors Learning

Keywords

learning, history, not, showing, up, visible, completed, items, tab, survey, missing, show, lms, admin, add, multiple, finance , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-EVA , Surveys , LOD-SF-LMS-ITE , Items , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-USR , User Entity , Problem

Product

SAP SuccessFactors Learning all versions