Symptom
Hire rule is not executed on hiring an employee in the previous year and accruals for the current year are also not posted
Environment
Successfactors - Employee Central
Reproducing the Issue
1. Time Account Type configuration is as shown below. A Hire rule has been assigned which should post amount based on seniority.
2. An Employee is hired in the previous year (8th Feb 2016) but on checking the Time Account the amount is not posted.
3. The Rule execution log is also empty which means that the hire rule did not get triggered.
Cause
Hire rule is not triggered for past accrual periods if the Time Account Type's Level of Accrual automation is set to 'No Automation'.
Resolution
Below is the working:
1. If the employee is hired in the previous year(outside the accrual period) and if the Time Account Type's Level of Accrual Automation is set to 'No Automation', then the hire rule will not trigger nor the accrual will be posted for the employee time account. In this case the Accrual calendar has to be manually run.
2. If the employee is hired in the previous year(outside the accrual period) and if the Time Account Type's Level of Accrual Automation is set to 'Automatic', then the hire rule and accrual rule will trigger and the accruals will be posted for the employee time account. There is no need to run the accrual calendar again.
Keywords
Time off Hire Recruit Rule Hire rule not executed Hire rule not triggered Accrual Hire Accrual , KBA , LOD-SF-EC-TIM , Time Off , Problem