Symptom
Customer requires the employees balance to be set to zero on termination.
They are using a termination rule to do so, however it is not setting the balance to zero.
Cause
This is currently not posible using the termination rule configuration.
Resolution
Setting the balance to 0 after termination, is currently only possible using an interim or period end processing rule and assigning this to the associated time account type.
There is no automatic way of doing this currently, as there is no event when the termination date is reached. Hence this must be checked periodically using the interim update or PEP calendar (depending on the use case).
Please see the Time Off Handbook section 3.3.11 Period-End Processing, and section 3.10 Interim Time Account Updates, on how to configure these rules.
We have an internal enhancement to provide this functionality, however no release date has been set as of yet.
Please see related KBA 2688247 - Support of "Termination End Processing" for Time Accounts
See Also
2149244 - TIME OFF : Configuring Period End Processing rule when employee has negative leave balance at the end of the year
Keywords
Termination, Zero, TIM-689 , KBA , LOD-SF-EC-TIM , Time Off , Problem