Symptom
When creating a Private Feed from within a Ticket this turns into a regular Ticket reference Feed.
Environment
Reproducing the Issue
- Go to the Service work centre.
- Go to the Tickets view.
- Open any relevant Ticket 123 (123 represents the Ticket ID).
- Go to the Feed facet.
-
Type (generally used to create a Private Feed) and enter an employee's name ABC (ABC represents the employee's name).
RESULT: ABC does not pup-up from a list and the Private Feed message does not show in the Ticket facet, however, it does show in the Feed work centre.
Cause
Private Feeds to objects are not allowed.
The function is only supported with reference to an Employee and additionally the @ feature can be combined to get the Feed on an object feed facet as well.
When you post a feed by following steps:
- Service Ticket Work Center
- FeedSubview
- Feed Post Update, this feed is treated as a reference on that Ticket.
But if you post using @Ticket No *Employee Name, then it means it is not referenced but is upon the Object - Tickets, in this case.
Resolution
This is expected system behaviour.
Keywords
Feeds, Ticket, Private Feeds , KBA , LOD-CRM-SRP , Service Request Processing , How To