Symptom
While querying /odata/v2/getPasswordPolicy or /odata/v2/ExternalUser, the following error is thrown:
[Error Code: 10] An error has occurred, please contact the system administrator
Environment
Successfactors HCM suite
Cause
The OData entities getPasswordPolicy or ExternalUser are specially designed for external users, which can be either external learning users or external onboarding users. So in order for these entities to be applicable at least one of the following features has to be enabled in the backend:
- EXTERNAL_LEARNING_USER
- ONBOARDING_2_APPLICATION
Resolution
- If either Learning or Onboarding modules are being used and this behaviour is noticed, please contact the Support Team so the Backend configuration can be verified.
- If the behaviour is noticed in a system without external Users [not using Learning and/or Onboarding] these entities are not applicable so the error message is the expected behaviour.
Keywords
[Error Code: 10] An error has occurred, please contact the system administrator, getPasswordPolicy, OData API, Error 10, ExternalUser , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT , Integrations , LOD-SF-INT-ODATA , OData API Framework , Problem