SAP Knowledge Base Article - Public

2460141 - The Is Primary Field is Missing from Emergency Contact Information

Symptom

The Is Primary filed is missing from reporting

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Advanced Reporting

Reproducing the Issue

  1. Access the Instance
  2. Go to Analytics
  3. Pull the Emergency contact information table
  4. Notice that the Is primary field is missing:

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Cause

The Is Primary field is a system field and will not be exposed to reporting schema

Resolution

The Primary_flag field needs to be configured through Manage Business Configuration:

  1. Go to Manage Business Configuration
  2. Select emergencyContact Primary
  3. Click on Details

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  1. Add Primary Flag, In the Details section please maintain the fields according to the screenshot (Primary flag details):

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  1. Save
  2. Once you make above configuration Primary flag will be shown in reporting tool
  3. After this configuration, if you still cannot locate the Is Primary field, please run a metadata refresh by following the 2776882 KBA.

Keywords

SF, success factors, ANA, RPT, Is Primary, Advanced Reporting, Canvas, Emergency Contact Information , KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-EC-REP , Reporting Data (EC core only) , How To

Product

SAP SuccessFactors HCM suite all versions ; SAP SuccessFactors Workforce Analytics all versions