Symptom
The Is Primary filed is missing from reporting
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Advanced Reporting
Reproducing the Issue
- Access the Instance
- Go to Analytics
- Pull the Emergency contact information table
- Notice that the Is primary field is missing:
Cause
The Is Primary field is a system field and will not be exposed to reporting schema
Resolution
The Primary_flag field needs to be configured through Manage Business Configuration:
- Go to Manage Business Configuration
- Select emergencyContact Primary
- Click on Details
- Add Primary Flag, In the Details section please maintain the fields according to the screenshot (Primary flag details):
- Save
- Once you make above configuration Primary flag will be shown in reporting tool
- After this configuration, if you still cannot locate the Is Primary field, please run a metadata refresh by following the 2776882 KBA.
Keywords
SF, success factors, ANA, RPT, Is Primary, Advanced Reporting, Canvas, Emergency Contact Information , KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-EC-REP , Reporting Data (EC core only) , How To
Product
SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Workforce Analytics all versions