Symptom
You have observed that for some business objects in the system (for example, Services), the IDs which are generated by the system are not consecutive / sequence, sometimes skipping one or more numbers.
Environment
SAP Business ByDesign
Reproducing the Issue
Following our example, we will detail how to observe this for services — however, this can be observed in other business objects as well.
- Go to the Product and Service Portfolio work center.
- Alternatively, this can also be done in the Product Data work center.
- Access the Services view.
- Change the selection to All Services.
- Click the header of the Service ID column and set to Sort Ascending.
- Browsing through the list of services, you can see some IDs are not present.
Cause
The reason behind this is because, for performance reasons, the drawing of IDs for products is buffered — i.e. when a new number is requested, the numbers are determined and reserved immediately. This helps to speed up mass creation of records significantly, but it has the side effect that after some time, the reserved numbers in the buffer are invalidated and thus not used.
Additionally, when an attempt to create a record fails or is canceled, that ID is usually invalidated as well.
Resolution
This is the standard system behavior. As mentioned previously, this is also true for other business objects beyond Services, which was used in this article only as an example.
Keywords
IDs, Consecutive, Gap, Services, sequence , KBA , service id , product , service id is not in sequence , ids , consecutive , gap , services , SRD-MD-PRD-SRV , Service , AP-RC-NR , Number Ranges (SAP Business ByDesign) , How To