Symptom
Filter search for username does not render results in dashboards and Ad Hoc reports.
Environment
SAP SuccessFactors Ad Hoc reporting
SAP SuccessFactors Dashboards
SAP SuccessFactors Report Center
Reproducing the Issue
- Edit an Ad Hoc report or run/edit a Dashboard
- Edit the People Scope and change the Team View for to a specific user, from the default one (Logged in user)
- In the screen that pops up, try searching for the desired user with the username - no results found
- Try searching for the same user based on the other fileds - results found
Cause
Hide (user name) in the UI is enabled in the provisioning.
Resolution
The fix requries access to Provisioning.
Please contact your Implementation partner or contact Product support, to implement the below fix:
- Login to Provisioning and select the company under concern.
- Access Company Settings
- Locate the 'Hide (user name) in the UI' check box and disable it.
- Save the changes in provisioning.
Keywords
Username, Filter, Search, Filter search for Username, People Scope, Dashboards, Ad Hoc, Report - Table , KBA , LOD-SF-ANA-DSH , YouCalc Dashboards and Tiles (Dashboards 2.0) , Problem
Product
SAP SuccessFactors HCM Suite all versions