SAP Knowledge Base Article - Public

2460837 - Product Image Imported Through Data Workbench Not Displayed in Products Work Center

Symptom

After the import of a product image using the Attachments import in Data Workbench, the image is not displayed properly in the Product OWL or overview.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Products workcenter.
  2. Access either the Products or Product Administration work center.
  3. Search for the relevant Product ID.
  4. Under the Image column, no image is displayed.
  5. Open the product record.
  6. Navigate to the Attachments tab.
  7. The image attachment imported through Data Workbench is correctly listed as part of this product, but type is listed as Standard Attachment instead of Product Image.

Cause

When an attachment is imported using a web link as source in the manifest file, it is created as an attachment of category 3 (Link). Attachments of this category are always added to the object with type Standard Attachment.

Resolution

In order to successfully import the attachment as type Product Image and have it successfully displayed in the Products work center views, please use source as file path in the manifest file and provide the image file along the manifest ZIP which must be imported. Type code to be used in these operations should be 10011.

See Also

2322155 - How to Upload Attachments Using Data Workbench

Keywords

Data Workbench, Attachments, Icon, Picture, Available, Shown, Product Image , KBA , product images , LOD-CRM-INT-DWB , Data Workbench , AP-RC-DOC , Document Centric Application Service , How To

Product

SAP Cloud for Customer add-ins all versions