Symptom
National IDs have been assigned incorrectly through import. For example, User1 has National ID of User2 and User2 has National ID of User5 and so on. When trying to import the National IDs with correct data, the following error will appear "National ID details already existing in the system for some other employee".
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central
Cause
Duplicate National IDs are not allowed in the system.
Resolution
- Replace first letter of the National ID value in the import file for each employee with a fixed letter, e.g. letter ‘X’.
- Save the import file in csv format.
- Perform Full Purge National ID import with this file.
- Perform Full Purge National ID import again with the file that contains correct National ID details.
Keywords
mass delete, mass correction, correct national ID , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , LOD-SF-EC , Employee Central , How To
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions