Symptom
Why is the EC Alerts and Notification Job failing.
An example: The EC Alerts and Notifications job failed because it exceeded the daily scheduling threshold for execution. For more details on the threshold value, refer to KBA2315275.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Employee Central
Cause
The main cause of the EC Alerts and Notification Job failing is due to a thresholding issue.
If the EC Alerts and Notifications business rules are not correctly configured this can cause multiple alerts to be triggered when you would expect only one to.
This can cause thousands of Alerts and Notifications to be triggered and cause the Job to fail as it is not capable of processing such high volumes.
Resolution
Please check the EC Alert and Notification Business Rules in the instance, referring to the below KBA's to make correction to the Rule's configuration:
2302229 - Receiving Multiple EC Alerts and Notifications
2431478 - Example Configuration of an EC Alert and Notification Rule.
2462860 - How to Configure EC Alerts and Notifications to be sent on Staggered Dates/Intervals
2156278 - How to set up EC Alerts and Notification using Business Rules
Once the rules are corrected the EC Alert and Notification Job will need to be resubmitted.
If you are a customer please reach out to your Partner or Cloud Product Support for assistance with the below.
When setting up the EC Alerts and Notification Job again in Admin Center (from 1H 2023 Release) or Provisioning: Implementing and Managing Workflows:Scheduling Recurring Job for Regular Alert Triggering
For Scheduling any SF Job please refer to Guide Creating a Scheduled Job Request in Admin Center Chapter -Notes on Some Common Job Types
Set the job up first to run for a single occurrence.
create new job
In the "Job Parameters" Specify a date as Yesterday Date and run the job today:
Example: Today it is 01/24/2024
- In the "Job Parameters" :Specify a date (server time, MM/DD/YYYY, for example 11/29/2020. Select this only when you want to run the job once):01/23/2024
- created job - submit later
- Run it Now
Also:
The reasoning for this, is if you run the job since the last successful run date, the job will check all alerts and notifications within that period, including the volume of tickets which caused the job to fail in the first place.
This will subsequently cause the job to fail again, after a very long runtime.
By setting the job up to run once as of yesterday's date this will stop this from happening.
Once the single occurrence job completes you can then set up the recurring job as usual (1 time for a recurring job. ( once daily for recurring job ))
.
For Scheduling any SF Job please refer to Guide Creating a Scheduled Job Request in Admin Center Chapter -Notes on Some Common Job Types
To regularly check which records are valid for alerts and create and send alert messages accordingly
EC Alerts and Notifications :The maximum times that the job can run each day in the Admin Center:
-
10 times a day.
-
1 time for a recurring job. ( once daily for recurring job )
Further detail of which can be found in the below KBA:
- 2156278 - How to set up EC Alerts and Notification using Business Rules
- 2677124 - EC Alerts: System Logic for when a saveAlert Rule is Removed or Changed
- Guide: Employee Central Workflows: Implementation and Administration
- Since B2305 release (Post release- 2305): customer can schedule some job such as: EC Alerts and Notification Via UI View: Creating a Scheduled Job Request in Admin Center
See Also
2156278 - How to set up EC Alerts and Notification using Business Rules
2431478 - Example Configuration of an EC Alert and Notification Rule.
2462860 - How to Configure EC Alerts and Notifications to be sent on Staggered Dates/Intervals
2302229 - Receiving Multiple EC Alerts and Notifications
Keywords
Alerts, Notification, Business Rules, Employee Central, EC, EC Alerts and Notification, job, failing, Full exception:com.successfactors.jobscheduler.ScheduledJobExecutionException: The EC Alerts and Notifications job failed because it exceeded the daily scheduling threshold for execution. For more details on the threshold value, refer to KBA2315275. , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem