Symptom
You are receiving the following error during replication of employees from SAP CRM to C4C
Employee XYZ is assigned to Org Unit ABC from DD.MM.YYYY to DD.MM.YYYY
Where XYZ corresponds to employee ID.
Where ABC corresponds to org unit ID and DD.MM.YYYY corresponds to org unit validity.
Reproducing the Issue
- Go to Master Data Replication and select Employees view
- Select to show Failed/Not Started records
- Select a failed record
- You find the same error as described above
Cause
The error happens because you are maintaining multiple organizational assignments for the employee.
You can verify the same following the steps below
- Go to Master Data Replication and select Employees view
- Select the employee and click on Edit
- Go to Organizational Assignment tab
- You see the employee is assigned to more than one org unit for the same period
To support multiple organizational assignments in replication of Employees from CRM it is necessary to implement a BADI in your CRM as documented in following integration guides
Integrating SAP Hybris Cloud for Customer with SAP CRM using SAP Process Integration
Integrating SAP Hybris Cloud for Customer with SAP CRM using SAP HANA Cloud Integration
See text below taken from pg.57 of integration guide
"You can now assign multiple organizations to an employee in SAP Hybris Cloud for Customer. In SAP CRM, you need to implement the BAdI CRMPCD_EMPLOYEE_OUTBOUND(in CRM) and write a custom logic to determine the primary and secondary organization assignments for an employee.
You will see a new field, Role Code, that has been added under Organizational Assignment node that determines primary and secondary organization assignments. You need to upgrade your integration content for SAP CRM Employee Replication to use this feature"
Resolution
Implement the BADI as described above or use only one organizational assignment in employee replication.
Keywords
KBA , LOD-CRM-EMP , Employee , How To