SAP Knowledge Base Article - Public

2465393 - Invoice Schedule Does Not Display Dates Outside the Validity of the Item for Migrated Contracts

Symptom

You migrated customer contracts but only the invoice schedule dates within the contract item validity are visible.

Reproducing the Issue

Prerequisite: You migrated a customer contract with invoice schedule dates outside the contracts validity.

  1. Go to the Sales Orders work center.
  2. Select the Contracts view.
  3. Search for contract XYZ (XYZ represents the ID of the contract).
  4. Click on the Edit button. 
  5. Navigate to the Pricing and Invoicing tab.
  6. Expand the line item XX (XX represents the number of the line item).

You can see that the invoice dates which are not within the start and end date of the contract item are missing for this item.

 

Cause

The system generates only those dates which lie within the validity of the item (contract item start and end date). Since missing invoice schedule dates are not within the contract item start and end date these dates are not generated in the invoice schedule.

 

Resolution

This is the expected system behaviour.

You can these invoice schedule dates manually in the contract:

  1. Go to the Sales Orders work center.
  2. Select the Contracts view.
  3. Search for contract XYZ (XYZ represents the ID of the contract).
  4. Click on the Edit button. 
  5. Navigate to the Pricing and Invoicing tab.
  6. Expand the line item XX.
  7. Click on the Add Date button.
  8. Maintain the respective invoice date.

Keywords

KBA , AP-PRP , Purchase Request Processing , How To

Product

SAP BUSINESS BYDESIGN 1611 ; SAP BUSINESS BYDESIGN 1705 ; SAP Business ByDesign 1608 ; SAP Business ByDesign 1702