Symptom
You migrated customer contracts but only the invoice schedule dates within the contract item validity are visible.
Reproducing the Issue
Prerequisite: You migrated a customer contract with invoice schedule dates outside the contracts validity.
- Go to the Sales Orders work center.
- Select the Contracts view.
- Search for contract XYZ (XYZ represents the ID of the contract).
- Click on the Edit button.
- Navigate to the Pricing and Invoicing tab.
- Expand the line item XX (XX represents the number of the line item).
You can see that the invoice dates which are not within the start and end date of the contract item are missing for this item.
Cause
The system generates only those dates which lie within the validity of the item (contract item start and end date). Since missing invoice schedule dates are not within the contract item start and end date these dates are not generated in the invoice schedule.
Resolution
This is the expected system behaviour.
You can these invoice schedule dates manually in the contract:
- Go to the Sales Orders work center.
- Select the Contracts view.
- Search for contract XYZ (XYZ represents the ID of the contract).
- Click on the Edit button.
- Navigate to the Pricing and Invoicing tab.
- Expand the line item XX.
- Click on the Add Date button.
- Maintain the respective invoice date.
Keywords
KBA , AP-PRP , Purchase Request Processing , How To